Jalan - no reviews on 2020-03-16 due to maintenance on the Jalan website

Minor incident Global Sources Jalan.net
2020-03-16 09:30 CEST · 1 day, 3 hours, 55 minutes

Updates

Resolved

Reviews are now coming in.

November 4, 2021 · 16:24 CEST
Issue

Jalan - no reviews on 2020-03-16 due to maintenance on the Jalan website. Now that the maintenance is over, we expect the reviews to be received as usual from tomorrow on. If all is fine tomorrow, this incident can be closed.

November 4, 2021 · 16:24 CEST

← Back