Agoda - experiencing delays in obtaining reviews for some (not all) hotels

Minor incident Global Sources
2020-03-10 07:41 CEST · 1 month, 2 weeks, 4 days, 4 hours, 52 minutes

Updates

Resolved

The problem was solved. Reviews are coming in again!

November 4, 2021 · 16:24 CEST
Investigating

The delays in obtaining review have been fixed. Reviews are coming in again.

November 4, 2021 · 16:24 CEST
Investigating

Agoda - experiencing delays in obtaining reviews for some (not all) hotels.

November 4, 2021 · 16:24 CEST

← Back