Crawling issues - Google

Major incident Global Sources Google
2022-02-14 11:03 CEST · 2 weeks, 2 days, 5 hours, 24 minutes

Updates

Resolved

The crawling issues have been resolved. The reviews are coming in.

March 2, 2022 · 16:27 CEST
Issue

We’re experiencing crawling issues, no new reviews are being crawled.

February 14, 2022 · 11:04 CEST

← Back