Crawling issues - Ikyu.com business

Major incident Global Sources Ikyu.com business
2022-02-10 09:40 CEST · 3 weeks, 4 days, 5 hours, 28 minutes

Updates

Resolved

The extractor has been fixed. The reviews are coming in.

March 7, 2022 · 15:09 CEST
Issue

Extractor is not working.

February 10, 2022 · 09:41 CEST

← Back