trip.com - experiencing data correctness issues.

Minor incident Global Sources Trip.com
2019-12-12 15:41 CEST · 8 months, 4 weeks, 1 day, 23 hours, 12 minutes

Updates

Resolved

Issue resolved

November 4, 2021 · 16:24 CEST
Issue

Please note that we are constantly working on this issue by finding and marking duplicates accordingly.

We are experiencing duplicated reviews between trip.com and Ctrip.

This happens due to the fact that both trip.com and Ctrip are subsidiaries of Trip.com Group and may show cross-domain reviews.

November 4, 2021 · 16:24 CEST

← Back