Holidaycheck reviews

Major incident Global Sources HolidayCheck
2021-03-23 11:12 CEST · 20 hours, 46 minutes

Updates

Resolved

Service is back to normal

November 4, 2021 · 16:25 CEST
Investigating

Some properties are not receiving holidaycheck reviews due to an outage in the system

November 4, 2021 · 16:25 CEST

← Back