Booking reviews

Major incident Global Sources Booking.com
2021-03-21 10:07 CEST · 2 days, 21 hours, 51 minutes

Updates

Resolved

Service is back to normal

November 4, 2021 · 16:25 CEST
Investigating

Some properties are not receiving booking reviews due to an outage in the system.

November 4, 2021 · 16:25 CEST

← Back