Delay in new reviews and responses

Major incident Global Sources Agoda AirBNB Booking.com Ctrip Expedia Google Hostelworld Hotels.com HRS.de Orbitz Travelocity Trip.com TripAdvisor EMEA Sources HolidayCheck Hotel.de Staycation.co TOPHotels.ru TUI Yandex.ru APAC Sources Dianping Fliggy Lvmama MakeMyTrip Meituan Qunar Traveloka Elong Japan Sources Jalan.net Ikyu.com business Rakuten Travel Rurubu.travel
2023-10-19 02:00 CEST · 1 day, 5 hours, 18 minutes

Updates

Resolved

The incident was resolved and reviews and responses are back in sync

October 20, 2023 · 07:18 CEST
Issue

There is an incident that is causing delays in the new reviews and responses. The team is already looking into it.

October 19, 2023 · 09:49 CEST

← Back