Google.com - Duplicated Data

Minor incident Global Sources Google
2023-06-26 00:00 CEST · 4 weeks, 7 hours, 29 minutes

Updates

Resolved

A fix was released and duplicates caused by A/B testing were cleaned up.

July 24, 2023 · 07:28 CEST
Update

We have deployed the Google duplication fix and cleaned up the bad data(+some good data as there is no cleaner way to identify only bad data) crawled after 1 March 2023.

All the deleted reviews are expected to be crawled back with correct review/response text in next 24-48 hours.

Thus, please be aware that there will be missing reviews and other anomalies may be observed until end of Wednesday(19 July).

July 17, 2023 · 20:45 CEST
Issue

Google is A/B testing with translated reviews/responses. This is leading to duplicates of original/translated reviews/responses written in non-english languages for some properties.

June 29, 2023 · 11:38 CEST

← Back