Ctrip.com - Extractor Down

Major incident Global Sources Ctrip
2023-03-10 14:27 CEST · 1 week, 5 days, 23 hours, 34 minutes

Updates

Resolved

Incident resolved: the system is providing new reviews and responses again for ctrip.com

March 23, 2023 · 14:01 CEST
Issue

New reviews and responses are not provided by ctrip.com
Working on a fix.

March 10, 2023 · 14:28 CEST

← Back