Google - experiencing data availability issues

Major incident Global Sources Google
2020-03-23 14:57 CEST · 1 month, 2 weeks, 1 day, 23 hours, 52 minutes

Updates

Resolved

Google is gradually restoring users’ ability to write reviews by country and business category. They are also gradually publishing delayed user reviews and photos submitted to Google.
https://support.google.com/business/answer/9792336
https://support.google.com/business/answer/3474050?co=GENIE.Platform%3DAndroid&hl=en

November 4, 2021 · 16:24 CEST
Issue

Due to the Coronavirus (Covid-19) crisis, Google announced that the ability to push or respond to reviews is going to be affected. You can find the public statement here: https://support.google.com/business/answer/9792336?hl=en .<br>
For now, this means that you are no longer able to respond to Google reviews and you may experience a delay in new reviews going live.

November 4, 2021 · 16:24 CEST

← Back