Google.com - Extractor Dolwn

Major incident Global Sources Google
2023-06-05 09:44 CEST · 1 day, 2 hours, 2 minutes

Updates

Resolved

Incident resolved: the system is providing new reviews and responses again for google.com

June 6, 2023 · 11:45 CEST
Issue

New reviews and responses are not provided by this source. Working on a fix.

June 5, 2023 · 09:44 CEST

← Back